Mikey 7

Post pics of your car in here
Post Reply
heralue
Posts: 7
Joined: September 11th, 2006, 8:19 am
Location: Vaxjo, Smaaland, Sweden
Contact:

Mikey 7

Post by heralue » October 9th, 2006, 7:09 pm

It's a Locost "by the book"

I have made the frame on my own. The engine is a 130 Strada Abarth with twin Dellorto 40 DHLA. Gearbox and rear axle is Fiat 124 sport Coupe.
Attachments
fiat in action.jpg
fiat in action.jpg (259 KiB) Viewed 4995 times
6.jpg
6.jpg (88 KiB) Viewed 4995 times
IMGP1081_041030.JPG
IMGP1081_041030.JPG (79.69 KiB) Viewed 4992 times

Guy Croft
Site Admin
Posts: 5031
Joined: June 18th, 2006, 9:31 am
Location: Lincoln, UK
Contact:

Post by Guy Croft » October 10th, 2006, 7:49 am

I'm very impressed Micke, especially since I have never built a car!

The book is 'Build your own Sports Car', right?

I particularly like the nicely swept 4-1 exhaust header and radiused rampipes, plus the attention to good instrumentation!

Well done indeed,

GC

heralue
Posts: 7
Joined: September 11th, 2006, 8:19 am
Location: Vaxjo, Smaaland, Sweden
Contact:

Post by heralue » August 20th, 2007, 10:11 am

During this summer I removed my twin Dellorto 40's and installed my Megasquirt.
Attachments
DSC00036.JPG
DSC00036.JPG (49.08 KiB) Viewed 4233 times

Guy Croft
Site Admin
Posts: 5031
Joined: June 18th, 2006, 9:31 am
Location: Lincoln, UK
Contact:

Post by Guy Croft » August 20th, 2007, 10:29 am

... and....?!

GC

heralue
Posts: 7
Joined: September 11th, 2006, 8:19 am
Location: Vaxjo, Smaaland, Sweden
Contact:

Post by heralue » August 20th, 2007, 10:49 am

sorry about the picture from my telephone...
Now I'm driving with an Wide Band O2 lambda meter to adjust the the Megasquirt. It runs pretty good but it will take some time before it's perfect.
Attachments
DSC00035.JPG
DSC00035.JPG (46.02 KiB) Viewed 4231 times

heralue
Posts: 7
Joined: September 11th, 2006, 8:19 am
Location: Vaxjo, Smaaland, Sweden
Contact:

Post by heralue » September 26th, 2007, 10:17 am

A few weeks ago we were racing at an old airfield

I had some problem with my Megasquirt, suddenly the engine got VERY much petrol (it ran out of the exhaust !!!)
When I come home I found out that the two connections on the ignition coil (15 and 1) was mixed up !!!!!
Attachments
mikey7.jpg
mikey7.jpg (62.08 KiB) Viewed 4000 times

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests