dellorto DHLAs choking on left-handers

Competition engines and ancillaries - general discussion
Post Reply
1969race125
Posts: 40
Joined: July 27th, 2006, 5:42 am
Location: Wellington, New Zealand
Contact:

dellorto DHLAs choking on left-handers

Post by 1969race125 » July 27th, 2006, 6:08 am

Thought people might be interested in a problem we found with the dellorto DHLA 45's fitted to my 8V 2litre race motor (in a 1969 125). It's possibly a "known" problem but I couldn't find anything on the net about it and it took us a while to find a fix, so if anyone else has the problem I'm happy to share our solution.
Basically we would get fuel-related problems coming out of any tightish left-hand corner at race speed. We tried all the obvious things like fuel surge, fuel pressure and regulation, float levels, etc. etc. but nothing cured it properly. It always felt to me like it was choking. As soon the car got pointed in a straight line again, it would clear up and away we would go.
It turned out fuel was sloshing up the little hole underneath the top jet cover and effectively choking the carb. We fixed it by simply extending the jet covers with drilled blocks and refitting. Apparently this problem is unique to delortos fitted on the driver's left (UK passenger) side of a NS motor...
Will happily provide more detail and pics if anyone is interested.

FIAT125T
Posts: 23
Joined: July 12th, 2006, 4:45 am
Location: New Zealand
Contact:

Post by FIAT125T » July 29th, 2006, 10:33 pm

Is this Griff's old #34?
Keeper of a 125T the flyin' New Zealander Fiat.

1969race125
Posts: 40
Joined: July 27th, 2006, 5:42 am
Location: Wellington, New Zealand
Contact:

Post by 1969race125 » August 2nd, 2006, 5:13 am

I prefer to think of it as "Andrew's new #34" :)

To 125 racer - sorry I didn't see your reply - will take some pics and post tomorrow.

1969race125
Posts: 40
Joined: July 27th, 2006, 5:42 am
Location: Wellington, New Zealand
Contact:

Post by 1969race125 » August 2nd, 2006, 11:11 pm

As promised. Crude but effective...

Image

Image

Image

Image

Image

SteveNZ

Post by SteveNZ » August 4th, 2006, 12:48 pm

I know Trevor had a lot of problems with the carbs when he had it. Does it still have the same carbs?

btw, nice car you have there. I remember it when it was a bare shell. I have a few photos if you are interested. :)

1969race125
Posts: 40
Joined: July 27th, 2006, 5:42 am
Location: Wellington, New Zealand
Contact:

Post by 1969race125 » August 5th, 2006, 1:52 am

Hi Steve,

Yes they're the same carbs. Since doing the mod above, they have been faultless. Griff did a lot of work getting the fuel pump and pressure/flow set up just right.

Would love to see early photos! Griff showed me his photos when I bought the car, but I didn't get copies.

Send me a PM and I'll give you my contact details.

thank you

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests