Page 1 of 1

Have bearing problems despite off mod oil pan

Posted: Sat May 24, 2014 10:54 pm
by torkil
sump 002.JPG
sump 002.JPG (44.46 KiB) Viewed 2434 times
sump 002.JPG
sump 002.JPG (44.46 KiB) Viewed 2434 times
My oil system is not good enock in trackconditions ,i have scored bearings again . The oil system worked well last season ,but this spring with improwed handling ,now the system suffer again. Now i have tried to modyfi again , and hope that this will work, now i have made two trapdoors inorder to try to sorce the oil over the pick up,

This is the second crank since i started the x 1/9 projeckt, The oil system has 4 liters in capacity and i run 10/60 oil .syntethic oil


I have also placed a 13 row oil cooler in the front off the radiator,the previus placing dident have good flow ,so i had also over 100 degrees in oil temp,
If this dont work , i have to change crank and get a dry sump system , or perhaps use excisting oil pump and source oil direckt from a oil tank ,but to drain the sump is a big problem -
A electric surge pump must bee found first, Any tips welcome.

Re: Have bearing problems despite off mod oil pan

Posted: Sun May 25, 2014 2:16 pm
by Guy Croft
Hi Ove

can you delete those photos - way too big (one is over 1Meg) - and cannot see anything useful. Post some good ones please1

Problems:

1. 4 liters is not much oil in the sump!
2. Oil cooler presumably at the front of the car miles from the engine - not effective at cooling and high pressure drop in the lines.
3. Oil getting too hot.

Solutions?

1. Use a Laminova heat exchanger and cool the oil from the main cooling system. Put the Laminova in the engine bay and rig it to the (hot) outlet from the head.
2. Fit an oil pressure accumulator.

G

Re: Have bearing problems despite off mod oil pan

Posted: Tue May 27, 2014 8:12 am
by torkil
Thanks MR Croft

Try to listen and fix problems ,

Re: Have bearing problems despite off mod oil pan

Posted: Tue May 27, 2014 6:14 pm
by Will01
Interesting info Guy.
I was going to use an air cooled oil cooler on the Capri, although when the bigger engine goes in i really think this will be a much better option.

Re: Have bearing problems despite off mod oil pan

Posted: Tue May 27, 2014 6:22 pm
by Guy Croft
Ove,

I see you are trying to sell your accumulator. I would never buy/swap a used-one. If not installed correct with check valve or filter with anti-syphon valve especially from an engine with bearing problems - it will be full of bearing debris. Sorry!


I asked you to publish good photos of the sump you modified. Can you not do this? Good focus and 500kb max!!

G

Re: Have bearing problems despite off mod oil pan

Posted: Tue May 27, 2014 10:15 pm
by torkil
Guy Croft wrote:Ove,

I see you are trying to sell your accumulator. I would never buy/swap a used-one. If not installed correct with check valve or filter with anti-syphon valve especially from an engine with bearing problems - it will be full of bearing debris. Sorry!


I asked you to publish good photos of the sump you modified. Can you not do this? Good focus and 500kb max!!

G
The Accu sump has never been used by mee, This coms from a friend off mine exelent condition.

Re: Have bearing problems despite off mod oil pan

Posted: Wed May 28, 2014 11:19 am
by Guy Croft
Understood Ove.

Put some photos & the size in the sale section!

G