Intermittently oil light stays on for 1/1.5 seconds after start up

Question and answer direct with GC. Competition engines and 'live' projects only. Good photos to illustrate your post are expected.
Post Reply
Slim
Posts: 71
Joined: Wed Aug 07, 2013 10:37 pm
Location: Pembrokeshire, Wales, Uk
Contact:

Intermittently oil light stays on for 1/1.5 seconds after start up

Post by Slim » Wed Oct 14, 2015 7:51 pm

Hello

I have an intermittent issue with my Uno Turbo oil pressure/light. Randomly my oil light stays on for a second or so after start up, and at the same time it sounds tappy.

Do coolers/filters drain back to the sump while the engine is off? Possibly causing the pump to refill the system before working pressure is attained?

Does the oil go: sump-pump-crank-head-filter-cooler-sump?

I suspect it's the pump.

Thanks

Liam
GC_36

Guy Croft
Site Admin
Posts: 5004
Joined: Sun Jun 18, 2006 9:31 am
Location: Lincoln, UK
Contact:

Re: Intermittently oil light stays on for 1/1.5 seconds after start up

Post by Guy Croft » Thu Oct 15, 2015 2:27 am

not a good sign....

it certainly takes longer to crank up oil pressure without ignition on - than it does when it is energised - but no matter, there is no load on the bearings...

esp con rod bearings.... !

but here the engine starts - so oil pressure really should be almost instantaneous..

it is most likely rod bearings on the way out, not the pump, but sorry I just do not know enough about your engine build to comment qualitatively...



G
Guy Croft, owner

Slim
Posts: 71
Joined: Wed Aug 07, 2013 10:37 pm
Location: Pembrokeshire, Wales, Uk
Contact:

Re: Intermittently oil light stays on for 1/1.5 seconds after start up

Post by Slim » Thu Oct 15, 2015 7:08 am

Guy

If it is the bearings then I'm not too bothered as the engine is coming out this winter as a new build is on the cards. That said, the engine has covered relatively small mileage so I would be shocked if the bearings were worn to that extent!

I will investigate possible causes when I strip down.

Liam
GC_36

Will01
Posts: 557
Joined: Mon Nov 26, 2012 3:50 pm
Location: Dumfries, Scotland
Contact:

Re: Intermittently oil light stays on for 1/1.5 seconds after start up

Post by Will01 » Thu Oct 15, 2015 1:06 pm

i know you said Tappy sounding engine but could this just be cold engine?
As for oil pressure light have you checked all wiring and earth etc. When earth is poor signal can take a while maybe?
GC_21

Slim
Posts: 71
Joined: Wed Aug 07, 2013 10:37 pm
Location: Pembrokeshire, Wales, Uk
Contact:

Re: Intermittently oil light stays on for 1/1.5 seconds after start up

Post by Slim » Thu Oct 15, 2015 4:52 pm

Will

I can happen when the engine is hot so not just on cold start. It could be me just imagining the noise as the light seems to stay on longer sometimes. I have not checked the earth etc but will. Maybe I should clean connections and replace oil pressure sensor first.

Liam
GC_36

tmvolumex
Posts: 165
Joined: Fri Jul 07, 2006 12:43 am
Location: USA
Contact:

Re: Intermittently oil light stays on for 1/1.5 seconds after start up

Post by tmvolumex » Mon Oct 19, 2015 12:37 am

In my experience the oil pressure light sending units on Fiat cars, (my experience is with twin cams) does not last more than 50,000 miles or 5-7 years. I suspect that your Fiat Uno Turbo is older than that. If the sender controls the fuel pump, you find out real fast that either you have no oil or the sender went bad. The electric fuel pump will shut off with no oil pump pressure. I do not know if this applies to fuel injected cars but the carb cars have the fuel pump shut off if there is no oil pressure. Change the sending unit and see what happens. Since you are hearing tapping noises it does sound like the oil has drained down away from the tappets and into the sump or there is too much clearance in the pump or the engine bearings. I would check out the bottom end before the crank gets damaged.
Tom
GC_31

Slim
Posts: 71
Joined: Wed Aug 07, 2013 10:37 pm
Location: Pembrokeshire, Wales, Uk
Contact:

Re: Intermittently oil light stays on for 1/1.5 seconds after start up

Post by Slim » Wed Oct 21, 2015 10:06 am

Hi Tom

I agree, a new oil pressure sender unit needs replacing first. If there is no change then I will check pump clearances and big end bearings.

Liam
GC_36

Guy Croft
Site Admin
Posts: 5004
Joined: Sun Jun 18, 2006 9:31 am
Location: Lincoln, UK
Contact:

Re: Intermittently oil light stays on for 1/1.5 seconds after start up

Post by Guy Croft » Wed Oct 21, 2015 3:44 pm

Whoa, stop right there.

The light takes ages to go out? What does the gauge say? No pressure?

In an ideal situation the gauge flickers into life and registers pressure before the preset-pressure of the oil warning light is reached. The response should be a few seconds tops. Faster when cold?

Not really. The engine spins faster when hot. There is no fixed rule. Either way the oil pressure gauge should flicker into life almost instantly.

Fiat instruments from the 70s are completely USELESS! They are made from compliant materials that go stiff and give errant readings in ALL SITUATIONS!

Senders and gauges.

Stop guessing and hoping for the best here. Fit all new instruments and senders and then and only then hope for the best - but I think I will be proved right and this engine needs an exploratory strip to check the bearings.

Will those who disagree kindly desist!

Thank you.



GC
Guy Croft, owner

Slim
Posts: 71
Joined: Wed Aug 07, 2013 10:37 pm
Location: Pembrokeshire, Wales, Uk
Contact:

Re: Intermittently oil light stays on for 1/1.5 seconds after start up

Post by Slim » Wed Oct 21, 2015 6:06 pm

Guy

I will do what you advise.

Liam
GC_36

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest