Ignition Issue Lancia Twincam 2lt

Question and answer direct with GC. Competition engines and 'live' projects only. Good photos to illustrate your post are expected.
Post Reply
PeterLuxford
Posts: 3
Joined: Fri Apr 08, 2011 9:54 am
Contact:

Ignition Issue Lancia Twincam 2lt

Post by PeterLuxford » Sat Sep 26, 2015 3:51 am

I have a issue with the ignition system on my Lancia Stratos, which is running a Guy Croft 2lt twin cam with a super charger and electronic ignition. From cold it will start up and run fine for about ten minutes then suddenly it will cut out. At that point I no longer have a spark coming from the coil. Once it has cooled down for about an hour it will start and run again for about 10 minutes and the same think happens. To date I have changed the coil, the ignition module, the condenser and the HT leads. The only thing I can see wrong is that the revs seem to hunt a bit up and down, but the engine is running smoothly right up to the point when it cuts. Does anyone have any ideas as to what might be causing the issue?
GC_10

Guy Croft
Site Admin
Posts: 5004
Joined: Sun Jun 18, 2006 9:31 am
Location: Lincoln, UK
Contact:

Re: Ignition Issue Lancia Twincam 2lt

Post by Guy Croft » Sat Sep 26, 2015 9:55 am

1. Disconnect the tacho from the coil -ve and run it - see if it stops. Faulty tacho will stall the engine (maybe..) if there is a rev limiter in it
2. If tacho is good reconnect and run till stall, disconnect power module and crank it - check output signal from distributor.

I assume it is not simply a faulty fuel pump..?


G
Guy Croft, owner

PeterLuxford
Posts: 3
Joined: Fri Apr 08, 2011 9:54 am
Contact:

Re: Ignition Issue Lancia Twincam 2lt

Post by PeterLuxford » Sun Sep 27, 2015 6:37 am

Hi Guy,
Thanks for the response. I'm not getting a signal out of the distributor once it fails so I'm assuming its the pick-up sensor in the distributor which is faulty. I have one here which I should be able to use, if not I might be asking you to track one down for me.

Once again thanks for your help.

Peter.
GC_10

Guy Croft
Site Admin
Posts: 5004
Joined: Sun Jun 18, 2006 9:31 am
Location: Lincoln, UK
Contact:

Re: Ignition Issue Lancia Twincam 2lt

Post by Guy Croft » Sun Sep 27, 2015 8:35 am

OK Pete!

G
Guy Croft, owner

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests